Application DNS Resolution Errors
Incident Report for US1 - Anypoint Platform
Resolved
There have been no throttling errors in the past 60 minutes. We are resolving this incident. We will be providing an RCA via our support portal in the next 2 business days.
Posted Mar 14, 2017 - 13:14 PDT
Monitoring
We have re-enabled application deployments and updates in CloudHub.
AWS still throttles some API calls, which can cause your update to fail with a throttling error message such as "java.io.IOException: com.amazonaws.AmazonServiceException: Rate for operation ChangeResourceRecordSets exceeded". This is expected while AWS finishes to recover.
If your application update fails, please retry again after 5 minutes.
Important: to avoid further risks, we suggest only to attempt updating critical applications
Posted Mar 14, 2017 - 08:59 PDT
Update
AWS DNS propagation system is recovered, but API calls are still being throttled. Waiting for full recovery to enable deployments and redeployments for CloudHub
Posted Mar 14, 2017 - 07:02 PDT
Update
We continue to work with AWS engineers and are monitoring the situation closely
Posted Mar 14, 2017 - 01:15 PDT
Update
Application deployments remain blocked. Application DNS records have recovered but we are still experiencing delays updating new records
Posted Mar 13, 2017 - 22:41 PDT
Update
We have blocked deployments and updates of cloud-based applications to prevent potential application name resolution errors. Deployments will be marked as failed and can be retried later.
Posted Mar 13, 2017 - 20:07 PDT
Identified
We have confirmed errors for application name resolution for new deployments of cloud-based applications in Runtime Manager and have identified the issue and expect to have it resolved soon. We recommend not deploying or re-deploying cloud-based applications until this issue is resolved.
Posted Mar 13, 2017 - 19:06 PDT