AKS and RTF Interoperability issue
Incident Report for US1 - Anypoint Platform
Postmortem

Our commitment to you:
We sincerely apologize for the impact this issue caused you and your business. It is our goal to provide world-class service to our customers, and we are continuously assessing and improving our tools, processes, and architecture to provide our customers with the best service possible.

Root Cause Analysis Document Link: Customer may have been unable to restart applications after upgrading Kubernetes on Microsoft AKS to v1.25 - May 26th 2023

If you have additional questions or need further support, please open a case with Support via the Help portal.

Posted Jun 22, 2023 - 14:15 PDT

Resolved
The new images are now available.
Posted Jun 07, 2023 - 17:59 PDT
Monitoring
RTF customers running Mule workloads on self-managed Azure (AKS) platforms are advised to not upgrade their kubernetes infrastructure to version k8s1.25 due to a known cgroupsv2 interoperability issue with JDK8 used in the Runtimes. We will notify when a Mule Runtime update with the appropriate patch for this interoperability issue is available.
Posted May 23, 2023 - 16:53 PDT
This incident affected: Runtime Services (Runtime Fabric).