Anypoint Platform Release and Maintenance Window
Scheduled for May 15, 09:00 - 14:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 06, 2021 - 14:24 PDT
Scheduled
US: On Saturday, May 15, 2021 between 9AM and 2PM PDT (12PM - 5PM EDT, 4PM - 9PM UTC)

***New/enhanced feature releases***

API Community Manager
- Introducing new capabilities in Guided Setup and Diagnostics to simplify the profile permissions configuration process.
- Upgrade of API Console to 6.4.9
- New features in Api Console Component
- Make calls directly from the browser (bypassing salesforce experience cloud)
- Support credentials population in API Console
- Expandable request panel
- New capability to search in API Specifications, Documentation Pages and Custom Fields
- New componentes
- Custom Fields Table
- Custom Fields Pills

Anypoint Exchange
Accessibility improvements in Exchange with improved color contrasting of UI components.

***Bug fixes & back-end performance enhancement releases***

API Community Manager
Bug fixes (no downtime anticipated)


***Bug fixes & security updates***

Anypoint MQ
Bug fixes (no downtime anticipated)
Security updates.



***Downtime Announcement(s)***


ATTENTION: a 5 to 15 minutes service interruption is expected during this maintenance window …

We will be introducing the Cookies preferences link and banner so users of Anypoint Sign in public portals can manage their cookie preferences.
*** Service impact details:
* Applications:
- Anypoint Management Center
During the service interruption, there will be no impact to the applications.
During maintenance downtime:
* User Experience(UX): Anypoint Management Center scripts may be interrupted by the banner, in which case you will be prompted to provide explicit consent to opt-in to the cookies used on the site.
* API calls: API calls will not be impacted.


ATTENTION: a 1 to 5 minutes service interruption is expected during this maintenance window.

We will be performing a scheduled Tomcat and JDK version upgrade on part of the platform’s underlying infrastructure.
Service impact details:
* Applications:
Cloudhub logging
During the service interruption, there will be no impact to the applications.
During maintenance downtime:
* Existing Runtimes: are not impacted.
* User Experience(UX):
No data loss. However, Cloudhub logging users may not be able to access application logs.
* API calls: will not be impacted.
* Logs and Data: log and metric display data will be updated during the service interruption.


ATTENTION: a 15 minutes to 1 hour service interruption is expected during this maintenance window.

We will be performing a scheduled upgrade on part of the platform’s underlying infrastructure.
Service impact details:
* Applications:
- Mule Communication Manager
During the service interruption, there will be no impact to the applications.
During maintenance downtime:
* Existing Runtimes: are not impacted.
* User Experience(UX): Application management capabilities of Runtime Manager may be disrupted as some servers may appear as disconnected and unavailable. This will be temporary and the correct state of the application will be reflected after the update has been completed.
* API calls: API calls will not be impacted.
* Logs and Data: log and metric display data will be updated during the service interruption.


ATTENTION - Upcoming Release Announcement : This is a heads up regarding a planned deployment of the encryption at rest changes during the May 29 2021 Release window. The OSv1 POST/PUT/DELETE functionality will be disrupted for up to 15 minutes during the May 29 Maintenance Window.

Planned schedule -
US: On Saturday, May 29, 2021 between 9AM and 2PM PDT (12PM - 5PM EDT, 4PM - 9PM UTC)

As part of our efforts to enhance our security posture to best protect our customer data, we are updating our databases to have encryption at rest. Please see here for more details - https://help.mulesoft.com/s/article/Anypoint-Platform-CloudHub-Data-Migration-May-2021

Service impact details:
Application deployments through Runtime Manager will fail or will be delayed for up to an hour.

API deployments through API Manager will fail or will be delayed for up to an hour.

Design Center test experience will be degraded for up to an hour.

Application schedules can be delayed by up to an hour.

Applications using OSv1 (Mule 3.x) will not be able to write/update data while experiencing transaction failures. OSv1 POST/PUT/DELETE API calls will fail up to 15 mins.


During maintenance downtime:
Existing Runtimes/Applications: The existing applications that are running will not be impacted. However, updates and restarts will be delayed for up to an hour.
New Runtimes/Applications: Requests for new application deployment will be delayed for up to an hour.
User Experience(UX): Applications, DLB, VPNs and VPC UI will be in read-only mode. Updates will not work but assets will be visible and will not be impacted.
API Calls: OSv1 POST/PUT/DELETE API calls will fail for up to 15 mins. GET requests will continue to work.

CloudHub POST/PUT/PATCH/DELETE API calls will fail for up to 30 mins. GET requests will continue to work.
Metrics Data: Metrics data will be delayed by up to 30 mins.


Posted May 03, 2021 - 13:17 PDT
This scheduled maintenance affects: Anypoint Management Center (Access Management, Runtime Manager) and Runtime Services (Enhanced logging).