Anypoint Platform Release and Maintenance Window
Scheduled for Apr 17, 09:00 - 14:00 PDT
Update
*** ATTENTION: Up to 60 minutes of service disruption will affect Mulesoft Composer for Salesforce during this maintenance window.
We will be restarting the OCS and CFM databases to pick up configuration changes. ***

*** Service impact details:
* Applications:
Mulesoft Composer for Salesforce
During maintenance downtime:
* Existing Runtimes: are not impacted.
* User Experience(UX): Mulesoft Composer for Salesforce will experience service disruption while the databases are being restarted.
* API calls: Specific API calls to CFM and OCS services will be disrupted during database restarts.
* Logs and Data: will continue to be collected.
Posted Apr 06, 2021 - 15:03 PDT
Scheduled
On Saturday, April 17, 2021 between 9AM and 2PM PDT (12PM - 5PM EDT, 4PM - 9PM UTC)

***New/enhanced feature releases***

Anypoint Exchange
Introducing cookie consent management for Exchange public portals: Users of Exchange public portals can manage their cookie preferences.
Access Management
The Organizations resource “updatedAt” field now reflects the Subscription or Entitlements updates.

***Bug fixes & back-end performance enhancement releases***


- Anypoint API Designer & Mocking service
- Bug fixes, no downtime anticipated

***Downtime Announcement(s)***


During maintenance window API Manager will be in read-only mode:
- Runtimes: are not impacted.
- User Interface (UI): will display ”Unable to complete this request while services are undergoing maintenance. Please retry after maintenance has been completed.” for create or modify actions.
- API calls: to these services will return ”Unable to complete this request while services are undergoing maintenance. Please retry after maintenance has been completed.” for create or modify requests.



*** ATTENTION: A 30 min to 1 hour service interruption is expected during this maintenance window in the Flow Designer product.
We will delete the cache and database that saves the user configurations and connections. ***


*** Service impact details:

* Applications:

Flow Designer.

During maintenance downtime:

* Existing Runtimes: are not impacted.

* User Experience(UX): Flow Designer customers will experience service interruptions and slowness for up to 1 hour

* API calls: API calls which retrieves connections and configurations will experience slowness.

When the users want to see their Flow Designer connections or configurations, they have to wait that the information is available.
Configurations and connections are in the steps of the flow created by the user and they contain the information for connecting with user accounts (for example user and passwords/authentication tokens). Also the configurations could contain, for example, the listener url of the created application or similar data.

* Logs and Data: log and metric display data will be updated during the service interruption.




*** ATTENTION: Up to 90 minutes of service performance degradation is expected during this maintenance window for the Exchange Tooling Service.

We will be performing a scheduled upgrade on part of the platform underlying infrastructure.
*** Service Impact Details:
* Applications:
- Exchange
- Flow Designer
- CFM Connectivity Manager
- Composer Mule Adapter Service
During maintenance downtime:
- Runtimes: are not affected.
- User Interface (UI): will not show any additional information.
- API calls: to the exchange-tooling-service will be expected to increase their response times.
- Logs and Data: will continue to be collected.




*** ATTENTION: up to 3 hours 30 minutes of service interruption is expected during this maintenance window … ***

We will be performing a scheduled upgrade on part of the platform’s underlying infrastructure.
*** Service impact details:
* On Prem Servers and Applications:
During the service interruption, there will be no impact to the Runtimes. Applications and servers will be on read-only mode and sync back after the update is completed.
During maintenance downtime:
* Existing Runtimes: are not impacted.
* User Experience(UX): Platform alerts and platform messages usage will be interrupted. Some servers’ and applications’ discrete alerts could be interrupted.
* API calls: API calls will only work on read-only mode.
* Logs and Data: log and metric display data will be updated during the service interruption as long as the runtimes are not restarted. In the event runtimes are restarted, the logs and metrics data will not be updated during the service interruption, however it will be synced after the completion of the window if available.


Posted Apr 05, 2021 - 18:04 PDT
This scheduled maintenance affects: Design Center (Exchange, Flow Designer) and Anypoint Management Center (API Manager, Runtime Manager).